Back to overview
Downtime

Some services are down

Jun 12 at 02:57pm EDT
Affected services
Dashboard
Admin API
Scenario Executions
Responsive Webhooks

Resolved
Jun 12 at 09:40pm EDT

Service is back to normal.

Updated
Jun 12 at 04:26pm EDT

GCP and Cloudflare have been gradually resolving their outages. Our backlogs are caught up, and we are processing traffic at this point. We'll keep monitoring the situation and providing updates.

Updated
Jun 12 at 03:17pm EDT

Traffic has started flowing again, and the majority backlog that we do have is caught up.
We're currently investigating to see if we missed any traffic, but our providers are also still experiencing difficulties making the task a little more challenging.

Created
Jun 12 at 02:57pm EDT

Services are currently degraded. We're investigating issues with service availabiity with our provider Cloudflare.